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1  Introduction 

This document guides the users in quickly setting up A2B system. The document lists all the software 
and hardware requirements for running the sample demo and provides necessary information for 
demonstrating A2B bus capabilities.  

1.1  Document Usage Guideline 

Depending upon the need users are recommended to go through the documents as mentioned in 
Table 2.  

Table 2: Usage guidelines 

Purpose Recommendation 

Quick Sample Demo bring-up  Refer Section 5 – “AE_09_A2B_QuickStartGuide.pdf“. (This 
document) 

Create customized A2B 
schematics (Advanced users) 

Refer “AE_09_A2B_ SigmaStudio_UserGuide.pdf” .\Docs  - [3] 

Integrate A2B Stack to a 
custom platform 

Refer “AE_09_A2B_ Stack_UserGuide.pdf” .\Docs  - [2] 

Understand A2B driver (At 
Function level) 

Refer  “AE_09_A2B_Stack_API_Reference.chm” in .\Docs - [1] 

1.2  Scope 

This guide is intended to help the reader in setting up and running the sample demo on the A2B 
evaluation system.  

Section 5 of this document explains the procedure for running the sample demo using PC as Host. 
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2  System Requirements  

2.1.1  Software Requirements 

• SigmaStudio Version 4.7 

• A2B.dll and A2BStack.dll Plug-ins for SigmaStudio 

2.1.2  Hardware Requirements 

• A2B Evaluation Board configured as Master 

o EVAL-AD2428WD1BZ Rev1.1 package 

▪ Evaluation Board 

▪ 12V Power Supply 1.5A 

▪ USB Type A Male - Mini Type B Male cable 

▪ Twisted Pair A2B Cable with DuraClick connectors 

▪ ADUSB2EBZ (USBi) board with USB cable (1.7m or 10m) 

▪ 3.5mm Audio cable or male-male adapter 

o ADSP-SC584 EZ Board 1.3 BOM 2.2 

▪ Evaluation Board 

▪ 12V Power Supply 1.5A 

▪ Twisted Pair A2B Cable with DuraClick connectors 

o ADSP-SC573 EZ Board 1.3 BOM 1.9 

▪ Evaluation Board 

▪ 12V Power Supply 1.5A 

▪ Twisted Pair A2B Cable with DuraClick connectors 

o ADSP-SC589 MINI Board 1.5 

▪ Evaluation Board 

▪ 12V Power Supply 1.5A 

▪ Twisted Pair A2B Cable with DuraClick connectors 

• 1-3-Slave nodes 

o EVAL-AD2428WB1BZ Rev2.0 package 

▪ Evaluation Board EVAL-AD2428WB1BZ (Stereo In, Stereo Out, Stereo 
Microphones) 
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▪ Twisted Pair A2B Cable with DuraClick connectors (30cm or 4m) 

▪ 3.5mm Audio cable or male-male adapter 

o EVAL-AD2428WC1BZ Rev2.1 package 

▪ Evaluation Board EVAL-AD2428WC1BZ (4 Microphones) 

▪ Twisted Pair A2B Cable with DuraClick connectors (30cm or 4m) 

• Two (non-grounded) audio source devices (e.g. iPods) 

• Two audio sink devices (Self powered speakers with 3.5mm TRS connector recommended) 
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3  Hardware Setup 

3.1  Evaluation boards 

The Evaluation boards used in the demos are explained in the following subsections. 

3.1.1  EVAL-AD2428WD1BZ 

Figure 1 shows an EVAL-AD2428WD1BZ board which can be used as either an A2B master or 
slave node. The board has following components 

• AD2428 A2B transceiver 

• ADAU1452 SigmaDSP Audio Processor 

• 512K Self-Boot Memory (EEPROM) 

• S/PDIF Optical Connectors 

• Codec ADAU1761 

  

Figure 1: EVAL-AD2428WD1BZ board  
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3.1.2  ADSP-SC584 

The Figure 2 shows an ADSP-SC584 board which can be used as either an A2B master or slave 
node. The board has following components. 

• ADSP-SC584 processor 

• AD2425 (Master) 

• AD2425 (Master/Slave) 

• ADAU1962A DAC 

• ADAU1977 and ADAU1979 ADC 

• SPDIF In/Out 

 

Figure 2: ADSP-SC584 EZ board 

3.1.3  ADSP-SC573 

The Figure 3Figure 2 shows an ADSP-SC573 board which can be used as either an A2B master or 
slave node. The board has following components. 

• ADSP-SC573 processor 

• AD2425 (Master/Slave) 

• ADAU1962A DAC 

• ADAU1977 and ADAU1979 ADC 
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• SPDIF In/Out 

 

 Figure 3: ADSP-SC573 EZ board 

3.1.4  ADSP-SC589 MINI 

The Figure 4 shows an ADSP-SC589 MINI board which can be used as either an A2B master or 
slave node. The board has following components. 

• ADSP-SC589 processor 

• AD2425 (Master/Slave) 

• ADAU1761 CODEC 

• SPDIF In/Out  
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Figure 4: ADSP-SC589 MINI Board 

3.1.5  EVAL-AD2428WB1BZ 

The Figure 5 shows an EVAL-AD2428WB1BZ board which can be used as an A2B slave node. 
The board has following peripherals 

• AD2428 A2B transceiver 

• SigmaDSP with codec (ADAU1761) 

• 2 PDM Microphones 

• Push Button  

• EEPROM 
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Figure 5: EVAL-AD2428WB1BZ board 

3.1.6  EVAL-AD2428WC1BZ 

The Figure 6 shows an EVAL-AD2428WC1BZ board which can be used as an A2B slave node. 
The board has following peripherals 

• AD2428 A2B transceiver 

• 4 PDM Microphones 

  

Figure 6: EVAL-AD2428WC1BZ board 
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3.2  Connections 

To run the sample demo, the following setup connections are to be made. 

3.2.1  Evaluation boards 

A2B Evaluation boards shall be connected in the following order 

1. EVAL-AD2428WD1BZ (Master) <–>EVAL-AD2428WC1BZ (Slave0) <–> EVAL-
AD2428WB1BZ (Slave1) as shown in Figure 7. 

2. Connect twisted-pair wire between the “B” connector on the Master board and the “A” 
connector on the Slave 0 board. 

3. Connect twisted-pair wire between the “B” connector on the Slave 0 board and the “A” 
connector on the Slave 1 board. 

4. Connect 12V power supply to the power connector (P4) on AD2428WD1BZ board.  

Note: This connection is recommended for running the sample demo using PC as host. Refer 
Section 7 for more details on using BF27, ADSP-21489 or ADSP-SC584 as host processor. 

  

Figure 7: A2B Eval board connections 
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3.2.2  USBi 

• Attach an USBi cable to the master board connector P1 as shown in Figure 7. Other 
end of the cable should be connected to the PC. 

• This connection is required to override the schematic for the master node SigmaDSP 
ADAU1452. The connection is also used to directly control A2B system when PC is 
used as the target processor (no SDP-B board connected). 

3.2.3  Audio In/out 

• Connect separate audio sources (e.g., output from an iPod) to ‘Audio Line- in’ ports, 
shown in Figure 7, on AD2428WD1BZ and AD2428WB1BZ boards. 

• Connect separate audio sinks (e.g., active speakers) to ‘Audio Line-out’ ports, shown in 
Figure 7, on AD2428WD1BZ and AD2428WB1BZ boards. 

 

Note: Do not connect the audio source directly from PC to WB1BZ board as they can cause 
ground loop issues. If connected discovery will fail for WB1BZ and subsequent nodes. 
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4  PC Software Setup 

4.1  SigmaStudio Setup 

1. Install latest version of SigmaStudio from the link 

            www.analog.com/SigmaStudio  

2. Follow the instructions given in the website.  

4.1.1  Adding A2B Plug-in DLL to SigmaStudio 

1. Ensure A2B.dll is in SigmaStudio installation directory $:\Program Files\Analog 
Devices\SigmaStudio 4.x\ 

2. Launch SigmaStudio and select the “Add-Ins Browser” from the “Tools” menu. This will open 
a window as shown in Figure 8. 

 

Figure 8: Add-In browser of SigmaStudio 

3. Within the “Add-Ins Browser” window, select “Add DLL” from the “File” menu  

4. Browse to the folder containing A2B dll ($:\Program Files\Analog Devices\SigmaStudio 4.x\) 
and select A2B.dll for Open. 

5. Once the A2B.dll is added to the Add-Ins browser, save and close the window (No need to 
Add-In A2BStack.dll). 

6. This will enable A2B functionality in SigmaStudio. 

http://www.analog.com/SigmaStudio
http://www.analog.com/SigmaStudio
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5  Running the Sample Demo 

The following sections describe the procedure to run a sample demo on A2B evaluation boards. 
Make sure that all steps mentioned in Section 3  and 4 are completed before running the demo. 

The sample demo configuration is as shown in Figure 9. The audio source connected to slave 1 will 
be played out at master node. The microphone audio from slave 0 will be played out at slave 1. 

 

Figure 9: Sample A2B demo configuration 

The sample demo configuration can be run using PC, BF527, ADSP-21489, ADSP-SC854 as host 
processor. 

5.1  PC as Host 

Using SigmaStudio the A2B system can be directly controlled from a connected computer without 
involving a microcontroller or a DSP. This mode is helpful for quick testing of the capabilities of 
AD24xx without the need for a microcontroller in the system. A block diagram of a 3 node A2B 
system with PC as Host is shown in Figure 10.  
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Figure 10: A2B system with PC as Host   

5.1.1  System requirements 

• System Requirements as mentioned in Section 2  

5.1.2  Software Setup 

Setup PC software as explained in Section 4  

5.1.3  Hardware Setup 

Hardware connections shall be done as described in Section 3 .  

 Jumper settings 

Jumper settings (default) for EVAL-AD2428WD1BZ is as shown in Table 3. 

Table 3: Jumper Settings 

JP1 JP2 JP3 JP4 JP5 JP6 JP7 JP8 
JP9 JP10 JP11 

12/13 
JP14 

1-2 
1-2 & 

 3-4 
1-2 & 

3-4 
1-2 3-4 3-4 3-4 2-3 3-4 1-2 Open 1-2 
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 A2B Demo system 

All steps mentioned in Section 3  and 4 shall be completed before running the demo using PC as a 
Host. The demo system shall look as shown in Figure 7 . If using an equivalent Evaluation board but 
having a different A2B Transceiver part, then update the part-number using A2B Node’s drop-down 
in the schematic to match the Transceiver used. 

5.1.4  Running sample Demo 

The following steps describe the procedure to run a sample demo in PC mode 

1. Open A2B schematic from 
(.\Schematics\BF\A2BSchematics\adi_a2b_3NodeSampleDemoConfig.dspproj). 

  

Figure 11: Sample demo schematic in PC mode  

2. Make sure that .xml files are provided for programming SigmaDSPs (ADAU1361 and 
ADAU1452) on master and slave A2B evaluation boards as shown in Figure 12. This window 
can be accessed by Right-clicking on a peripheral and selecting ‘Peripheral Properties’. By 
checking ‘Program during discovery’ option the connected peripherals are programmed 
during the discovery process. 

Note: The adi_a2b_master_ADAU1452.xml, adi_a2b_master_ADAU1361.xml and 
adi_a2b_slave_ADAU1761.xml files are generated by saving the Capture window output for 
Master and Slave SigmaDSP schematics available in 
.\Schematics\BF\SigmaDSPSchematics\ folder. 
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Figure 12: Programming file for ADAU1761 connected to a slave node 

3. Make sure that USBi cable is connected to EVAL-AD2428WD1BZ board as shown in Figure 
7Figure 7  and the board is powered on. If prompted for USBi driver, provide $:\Program 
Files\Analog Devices\SigmaStudio 4.x\USB drivers\x64 as the install path. 

4. Click on “LinkCompileDownload” icon in SigmaStudio. This will start the discovery and 
configuration of A2B nodes and peripheral devices as per the schematic. 

5. After successful discovery and initialization audio routing can be observed as per the sample 
demo configuration shown in Figure 9. 

6. Adjust speaker volume levels as desired. In case default audio routing needs to be changed 
it can be done so by following Section 2.8 in [2]. 
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5.1.5  Audio Routing over A2B 

Audio routing over the A2B bus is controlled using the schematic defined for the master node 
SigmaDSP (acts as Audio Host). The master schematic provided with this release supports audio 
routing as per the sample A2B demo configuration as given in Figure 9. To override this routing the 
following steps shall be followed. Note that the steps suggested here shall be followed only if dynamic 
audio rerouting is desired. 

 

1. Open master node SigmaDSP schematic in SigmaStudio 
(.\Schematics\BF\SigmaDSPSchematics\adi_a2b_master_ADAU1452.dspproj). Make sure 
that USBi is connected to J12 on the Master board. 

2. Click on ‘LinkCompileConnect’ icon (Not LinkCompileDownload!) in SigmaStudio. 

3. Make modifications in schematic as per required data routing. 

4. Audio routing should happen as per the downloaded schematic. 

5. In case the SigmaDSP schematic needs to be downloaded without disturbing the already 
discovered A2B network, then ensure that “PLL reset is disabled” as shown in Figure 13 (This 
feature is available with SigmaStudio 3.15 release onwards). 

 

 

Figure 13: Downloading SigmaDSP without PLL reset 
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5.2  BF527 as HOST  

The sample demo can be run using BF527 as the host processor. In this case the host processor 
controls the discovery and programming of A2B nodes in the system. The block diagram of a 3 node 
A2B system with BF527 as Host is shown Figure 14. 

 

Figure 14: A2B system with BF527 as Host 

5.2.1  System requirements 

• System Requirements as mentioned in Section 2  

• CCES 2.10.1 or later 

• SDP-B board with BF527 (EVAL-SDP-CB1Z) - Rev1.3 used as Host 

• JTAG Emulator to program ADSP-BF527 DSP or Flash on SDP board 

5.2.2  Software Setup 

Setup PC software as explained in Section 4  

 CCES setup 

1. Install Cross Core Embedded Studio 2.10.1 or later from the link   

www.analog.com/cces 

2. Follow the instructions given in the website.  

http://www.analog.com/
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5.2.3  Hardware Setup 

Hardware connections shall be done as described in Section 3 . SDP-B board shall be mounted on 
EVAL-AD2428WD1BZ.  

 Jumper settings 

No configurable Jumpers available on SDP-B board. EVAL-AD2428WD1BZ jumpers shall be set 
as in Table 3. 

 A2B demo system 

After completing all the connections, the A2B system should look as shown in Figure 15. 

• Mount ‘Connector A’ of SDP-B on J5 of EVAL-AD2428WD1BZ 

• Connect a JTAG Emulator from PC to SDP-B board. 

 

Figure 15: BF527 based A2B setup 

5.2.4  Running sample Demo 

When using BF527 as the host, demo can be run either from flash or by downloading from CCES 
over JTAG. The following steps shall be followed depending on the preferred way of execution. 

1. Flash the SDP-B board with A2B target software (Section 5.2.5 ) 

 OR  

2. Download A2B target software from CCES after each power up (Section 5.2.6 ) 

JTAG 

12V 

Twister Pair 
cables 
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5.2.5  Flash SDP board with A2B target software 

1. Open CCES and import Target project into the workspace using ‘File->Import->Existing 
Projects into Workspace’ browse and select a2bstack_frmwrk-bf (available in 
.\ADI_A2B_Software-RelX.Y.Z\Target\examples\demo).  

2. Build the project using ‘Project->Build Project’ option. 

3. Run the Flash utility batch file from \Target\ examples\demo\a2b-bf\Flash depending on the 
type of Emulator used to connect to Target (Flash-ICE100.bat for ICE-1000). 

4. The batch utility will start flashing the board as shown in Figure 16. 

 

 

Figure 16: Programming Flash with Blackfin loader file 

5. After the flashing is complete disconnect from Target, remove JTAG and Reset the SDP-B 
board. 

5.2.6  Download A2B target software from CCES 

1. Open CCES and import Target project into the workspace using ‘File->Import->Existing 
Projects into Workspace’ browse and select a2bstack_frmwrk-bf (available in 
.\ADI_A2B_Software-RelX.Y.Z\Target\examples\demo).  

2. Build the project using ‘Project->Build Project’ option. 

3. Create a new debug configuration using Run->Debug Configurations, create new session, 
select ADSP-BF527 and click NEXT, select Emulator and click NEXT, choose In-Circuit 
Emulator platform (typically: ADSP527 via ICE-1000) and click NEXT, then click FINISH. 

4. Ensure Custom board support file BF527-SDP-HW-CCES.XML (.\Target\ examples \demo 
\a2b-bf \system\BF527-SDP-HW-CCES.XML) is applied as shown in Figure 17. 
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Figure 17: Custom Board Support 

5. Run the project by selecting a debug configuration. Ensure that JTAG is connected to the 
SDP-B board on the Master node. 

5.2.7  Audio Routing over A2B 

Audio routing over the A2B bus is controlled using the schematic defined for the master node 
SigmaDSP (acts as Audio Host) as explained in Section 5.1.5 . Following steps shall be followed to 
change the default audio routing. 

1. Open master node SigmaDSP schematic in SigmaStudio 
(.\Schematics\BF\SigmaDSPSchematics\adi_a2b_master_ADAU1452.dspproj).  

2. Make modifications in schematic as per required data routing. 

3. Generate the Programming file - adi_a2b_master_ADAU1452.xml (in the path 
.\Schematics\BF\A2BSchematics\xml) as explained in Section 2.2.3.2.3 of 
AE_09_A2B_SigmaStudio_UserGuide.pdf. 

4. Export Bus configuration file (adi_a2b_busConfig.c) as explained in the section 4.1.1 of 
AE_09_A2B_SigmaStudio_UserGuide.pdf. 

5. Build and Run the project as explained in the Section 5.2.6  
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5.3  ADSP-SC584 as HOST  

The sample demo can be run using ADSP-SC584 as the host. In this case the ARM core of host 
processor controls the discovery and programming of A2B nodes in the system. The block diagram 
of a 3 node A2B system with ADSP-SC584 as Host is shown. Figure 18 

 

Figure 18: A2B system with ADSP-SC584 as Host 

5.3.1  System requirements 

• System Requirements as given in Section 2  

• CCES 2.10.1 or later 

• Optional Accessory to program ADSP-SC584 DSP or on-board Flash: 

o ICE-1000 

5.3.2  Software Setup 

Setup PC software as mentioned in Section 4  

 CCES setup 

3 Install Cross Core Embedded Studio 2.10.1 or later from the link    

www.analog.com/cces 

4 Install the ADSP-SC5xx Board Support Package 2.0.2 from the link 
www.analog.com/en/design-center/evaluation-hardware-and-software/evaluation-boards-
kits/EVAL-ADSP-SC584.html#eb-overview 

http://www.analog.com/
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5.3.3  Hardware Setup 

Hardware set up described in Section 3 shall be followed. EVAL-AD2428WD1BZ shall be replaced 
with ADSP-SC584 EZ-Board as A2B master board. 

 ADSP-SC584 EZ Board settings 

Default switch and jumper settings are good for using U9 (A2B_M) as master on ADSP-SC584 
board. For other use cases refer evaluation board schematics [4] 

 Switch settings 

Default Switch setting for ADSP-SC584 as in [4] shall be followed. 

 Jumper settings 

Default Jumper setting for ADSP-SC584 as in [4]shall be followed. 

 A2B Demo system 

After completing all connections, the A2B system should look as shown in Figure 19. ADSP-SC584 
EZ-Board used as A2B master board with A2B cable connected to P9. 

• Connect a JTAG Emulator from PC to ADSP-SC584 EZ-Board. (1.3 BOM Rev 2.2) 

 

Figure 19: ADSP-SC584 based A2B setup 

P9 
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5.3.4  Running sample Demo 

When using ADSP-SC584 as the host, demo can be run either from flash or by downloading from 
CCES over JTAG. The following steps shall be followed depending on the preferred way of 
execution. 

1. Flash the ADSP SC584 EZ- board with A2B target software (Section 5.3.5 ) 

OR 

2. Download A2B target software from CCES after each power up (Section 5.3.6 ) 

5.3.5  Flash ADSP-SC584 Ez board with A2B target software 

1. Open CCES and import Target project into the workspace using ‘File->Import->Existing 
Projects into Workspace’ browse and select ‘a2bstack-frmwrk-sc58x’ (available in 
.\ADI_A2B_Software-RelX.Y.Z \Target\examples\demo\ a2b-adsp-sc58x).  

2. Build the project using ‘Project->Build Project’ option. 

3. Ensure SW1 position is at 0. Run the Flash utility batch file from \Target\examples\demo\a2b-
adsp-sc58x\Flash depending on the type of Emulator used to connect to Target (Flash-
ICE1000.bat for ICE 1000).  

4. The batch utility will start flashing the board as shown Figure 20 

 

 

Figure 20: Programming Flash with ADSP SC584 loader file 

5. After the flashing is complete disconnect from Target, set SW1 position to 1, remove JTAG 
and reset the EZ board. 

5.3.6  Download A2B target software from CCES 

1. Open CCES and import Target project into the workspace using ‘File->Import->Existing 
Projects into Workspace’ browse and select ‘a2bstack-frmwrk-sc58x’ (available in 
.\ADI_A2B_Software-RelX.Y.Z \Target\examples\demo\ a2b-adsp-sc58x).  

2. Build the project using ‘Project->Build Project’ option. 
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3. Run the project by selecting a debug configuration. Ensure that JTAG is connected to the 
ADSP-SC584 EZ board on the Master node. 

Note: If Emulator is used the first tme: Create a new debug configuration using Run->Debug 
Configurations, create new session, select ADSP-SC584 and click NEXT, select Emulator 
and click NEXT, choose In-Circuit Emulator platform (typically: ADSP-SC584 via ICE1000) 
and click NEXT, then click FINISH. 

4. Run (F5). 

 

5.3.7  Audio Routing over A2B 

Audio routing over the A2B bus is controlled by the audio routing table which is part of ADSP-SC58x 
target software. Following steps shall be followed to change the default audio routing at the Audio 
Host (SC58x) 

1. Open the file adi_a2b_audioroutingtable.c in an editor (available in .\ADI_A2B_Software-
RelX.Y.Z \Target\examples\demo\a2b-adsp-sc58x\a2bstack-pal) 

2. The various fields of the routing table structure gaAudioRoutingtab are explained in Figure 
21. 

 

Figure 21 : Audio Routing Table Structure 
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3 The demo audio configuration and corresponding example audio routing table is as shown 
in Figure 22. To customize modify the routing against each downstream channel (fixed 
position). 

 

 Figure 22: Audio Routing with ADSP-SC584 as Host 

4 Build and Run the project as explained in Section 5.3.6  
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5.4  ADSP-SC573 as HOST  

The sample demo can be run using ADSP-SC573 as the host. In this case the ARM core of host 
processor controls the discovery and programming of A2B nodes in the system. The block diagram 
of a 3 node A2B system with ADSP-SC573 as Host is shown Figure 23. 

 

Figure 23: A2B system with ADSP-SC573 as Host 

5.4.1  System requirements 

• System Requirements as given in Section 2  

• CCES 2.10.1 or later 

• Optional Accessory to program ADSP-SC573 DSP or on-board Flash: 

o ICE-1000 

5.4.2  Software Setup 

Setup PC software as mentioned in Section 4  

 CCES setup 

1 Install Cross Core Embedded Studio 2.10.1 or later from the link    

www.analog.com/cces 

2 Install the ADSP-SC5xx Board Support Package 2.0.2 from the link 
https://www.analog.com/en/design-center/evaluation-hardware-and-software/evaluation-
boards-kits/SC573EZKIT.html 

http://www.analog.com/
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5.4.3  Hardware Setup 

Hardware set up described in Section 3 shall be followed. EVAL-AD2428WD1BZ shall be replaced 
with ADSP-SC573 EZ-Board as A2B master board. 

 ADSP-SC573 EZ Board settings 

Default switch and jumper settings are good for using U10 (A2B Master/Slave) as master on ADSP-
SC573 board. For other use cases refer evaluation board schematics [5]. 

 Switch settings 

Default Switch setting for ADSP-SC573 as in  [5] shall be followed. 

 Jumper settings 

Default Jumper setting for ADSP-SC573 as in [5] shall be followed. 

 A2B Demo system 

After completing all connections, the A2B system should look as shown in Figure 24. ADSP-SC573 
EZ-Board used as A2B master board with A2B cable connected to P11. 

• Connect a JTAG Emulator from PC to ADSP-SC573 EZ-Board. (1.3 BOM Rev 1.9) 
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Figure 24: ADSP-SC573 based A2B setup 

5.4.4  Running sample Demo 

When using ADSP-SC573 as the host, demo can be run either from flash or by downloading from 
CCES over JTAG. The following steps shall be followed depending on the preferred way of 
execution. 

1. Flash the ADSP SC573 EZ- board with A2B target software (Section 5.4.5 5.3.5 ) 

OR 

2. Download A2B target software from CCES after each power up (Section 5.4.6 ) 

5.4.5  Flash ADSP-SC573 Ez board with A2B target software 

1. Open CCES and import Target project into the workspace using ‘File->Import->Existing 
Projects into Workspace’ browse and select ‘a2bstack-frmwrk-sc57x’ (available in 
.\ADI_A2B_Software-RelX.Y.Z \Target\examples\demo).  

2. Build the project using ‘Project->Build Project’ option. 

P11 
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3. Ensure SW1 position is at 0. Run the Flash utility batch file from \Target\examples\demo\a2b-
adsp-sc57x\Flash depending on the type of Emulator used to connect to Target (Flash-
ICE1000.bat for ICE 1000).  

4. The batch utility will start flashing the board as shown Figure 25Figure 20 

 

 

Figure 25: Programming Flash with ADSP SC573 loader file 

5. After the flashing is complete disconnect from Target, set SW1 position to 1, remove JTAG 
and reset the EZ board. 

5.4.6  Download A2B target software from CCES 

1. Open CCES and import Target project into the workspace using ‘File->Import->Existing 
Projects into Workspace’ browse and select ‘a2bstack-frmwrk-sc57x’ (available in 
.\ADI_A2B_Software-RelX.Y.Z \Target\examples\demo).  

2. Build the project using ‘Project->Build Project’ option. 

3. Run the project by selecting a debug configuration. Ensure that JTAG is connected to the 
ADSP-SC573 EZ board on the Master node. 

Note: If Emulator is used the first time: Create a new debug configuration using Run->Debug 
Configurations, create new session, select ADSP-SC573 and click NEXT, select Emulator 
and click NEXT, choose In-Circuit Emulator platform (typically: ADSP-SC573 via ICE1000) 
and click NEXT, then click FINISH. 

4. Run (F5). 

 

5.4.7  Audio Routing over A2B 

Audio routing over the A2B bus is controlled by the audio routing table which is part of ADSP-SC57x 
target software. Following steps shall be followed to change the default audio routing at the Audio 
Host (SC57x) 
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1. Open the file adi_a2b_audioroutingtable.c in an editor (available in .\ADI_A2B_Software-
RelX.Y.Z \Target\examples\demo\a2b-adsp-sc57x\a2bstack-pal) 

2. The various fields of the routing table structure gaAudioRoutingtab are explained in Figure 
26Figure 21. 

 

Figure 26 : Audio Routing Table Structure 

 

3 The demo audio configuration and corresponding example audio routing table is as shown 
in Figure 27Figure 22. To customize modify the routing against each downstream channel 
(fixed position). 
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 Figure 27: Audio Routing with ADSP-SC573 as Host 

4 Build and Run the project as explained in Section 5.3.6 5.4.6  

 

5.5  ADSP-SC589 MINI as HOST  

The sample demo can be run using ADSP-SC589 MINI as the host. In this case the ARM core of 
host processor controls the discovery and programming of A2B nodes in the system. The block 
diagram of a 3 node A2B system with ADSP-SC589 as Host is shown Figure 28. 
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Figure 28: A2B system with ADSP-SC589 as Host 

5.5.1  System requirements 

• System Requirements as given in Section 2  

• CCES 2.10.1 or later 

• Optional Accessory to program ADSP-SC589 DSP or on-board Flash: 

o ICE-1000 

5.5.2  Software Setup 

Setup PC software as mentioned in Section 4  

 CCES setup 

1 Install Cross Core Embedded Studio 2.10.1 or later from the link    

www.analog.com/cces 

2 Install the ADSP-SC589 MINI Board Support Package 2.1.1 from the link 
https://wiki.analog.com/resources/tools-software/sharc-audio-
module/gettingstarted#installing_%E2%80%A6e_metal_sdk 

5.5.3  Hardware Setup 

Hardware set up described in Section 3 shall be followed. EVAL-AD2428WD1BZ shall be replaced 
with ADSP-SC589 MINI Board as A2B master board. 

http://www.analog.com/
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 ADSP-SC589 MINI Board settings 

Default switch and jumper settings are good for using U16 (A2B Master/Slave) as master on ADSP-
SC589 MINI board. For other use cases refer evaluation board schematics [6] 

 Switch settings 

Default Switch setting for ADSP-SC589 MINI as in [6] shall be followed. 

 Jumper settings 

Default Jumper setting for ADSP-SC589 MINI as in [6] shall be followed. 

 A2B Demo system 

After completing all connections, the A2B system should look as shown in Figure 29. ADSP-SC589 
MINI Board used as A2B master board with A2B cable connected to P7. 

• Connect a JTAG Emulator from PC to ADSP-SC589 MINI Board. (Rev 1.5) 

 

Figure 29: ADSP-SC589 based A2B setup 
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5.5.4  Running sample Demo 

When using ADSP-SC589 mini as the host, demo can be run either from flash or by downloading 
from CCES over JTAG. The following steps shall be followed depending on the preferred way of 
execution. 

1. Flash the ADSP SC589 MINI EZ Board with A2B target software (Section 5.5.5 ) 

OR 

2. Download A2B target software from CCES after each power up (Section 5.5.6 ) 

5.5.5  Flash ADSP-SC589 MINI board with A2B target software 

1. Open CCES and import Target project into the workspace using ‘File->Import->Existing 
Projects into Workspace’ browse and select ‘a2bstack-frmwrk-sc58x’ (available in 
.\ADI_A2B_Software-RelX.Y.Z \Target\examples\demo\ a2b-adsp-sc589_mini).  

2. Build the project using ‘Project->Build Project’ option. 

3. Run the Flash utility batch file from \Target\examples\demo\ a2b-adsp-sc589_mini \Flash 
depending on the type of Emulator used to connect to Target (Flash-ICE1000.bat for ICE 
1000). 

4. The batch utility will start flashing the board as shown Figure 30 

 

 

Figure 30: Programming Flash with ADSP SC589 mini loader file 

5. After the flashing is complete disconnect from Target, Connect JP1 to boot mode, remove 
JTAG and reset the EZ board. 

5.5.6  Download A2B target software from CCES 

1. Open CCES and import Target project into the workspace using ‘File->Import->Existing 
Projects into Workspace’ browse and select ‘a2bstack-frmwrk-sc58x’ (available in 
.\ADI_A2B_Software-RelX.Y.Z \Target\examples\demo\a2b-adsp-sc589_mini).  

2. Build the project using ‘Project->Build Project’ option. 
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3. Run the project by selecting a debug configuration. Ensure that JTAG is connected to the 
ADSP-SC589 mini board on the Master node. 

Note: If Emulator is used the first time: Create a new debug configuration using Run->Debug 
Configurations, create new session, select ADSP-SC589 and click NEXT, select Emulator 
and click NEXT, choose In-Circuit Emulator platform (typically: ADSP-SC589 via ICE1000) 
and click NEXT, then click FINISH. 

4. Run (F5). 

 

5.5.7  Audio Routing over A2B 

Audio routing over the A2B bus is controlled by the audio routing table which is part of ADSP-SC589-
mini target software. Following steps shall be followed to change the default audio routing at the 
Audio Host (SC589) 

1. Open the file adi_a2b_audioroutingtable.c in an editor (available in .\ADI_A2B_Software-
RelX.Y.Z \Target\examples\demo\a2b-adsp-sc589_mini\a2bstack-pal) 

2. The various fields of the routing table structure gaAudioRoutingtab are explained in Figure 
31. 

 

Figure 31 : Audio Routing Table Structure 
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3 The demo audio configuration and corresponding example audio routing table is as shown 
in Figure 32. To customize modify the routing against each downstream channel (fixed 
position). 

 

 Figure 32: Audio Routing with ADSP-SC589 as Host 

4 Build and Run the project as explained in Section 5.5.6 . 
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Terminology 

Table 4: Terminology 

Term Description 

A2B Automotive Audio Bus 

API Application Programming Interface 

DSP Digital Signal Processor 

EEPROM Electrically Erasable Programmable Read Only Memory 

USB Universal Serial Bus 

TWI Two Wire Interface 

PDM Pulse Density Modulation 
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